Author Topic: Input Delay Issue  (Read 102 times)

0 Members and 1 Guest are viewing this topic.

Input Delay Issue
« on: July 25, 2020, 04:02:12 PM »
So, I've been having this issue for over a week now, and I've basically tried everything I could. I keep feeling a slight input delay in most of my Touhou games, and I don't know why. Maybe it's a self-fulfilling prophecy, but I personally don't think so.

Things I tried:
Turning "Disable Fullscreen Optimization" on.
Reinstalling ALL of my Touhou games.
Fiddling around with my vpatch files.
Running the games in Japanese Locale.
Resetting my ENTIRE PC
Turning Game Mode off.
(I probably did some other stuff too)


I've considered buying a new PC/Keyboard, but I hope that I won't have to. There has to be another solution, right? I just don't know what to do anymore. Can anyone help me out?

Re: Input Delay Issue
« Reply #1 on: July 25, 2020, 08:37:47 PM »
Which games, all of them?

Keep "Disable Fullscreen Optimization" enabled.
For Touhou 6-9.5 use the d3d8 converter. Without it, you get windowed fullscreen --> input lag.
Use vpatch and go in fullscreen. You should see screen tearing - this is the lowest input lag you can get.

Edit: make sure vpatch settings are sensible (no vsync!) or default.

Agent BSoD

  • Takeminakata Invocation
  • Never forget
    • Twitch
    • YouTube
Re: Input Delay Issue
« Reply #2 on: July 25, 2020, 11:13:43 PM »
Personally, I've never had to use a d3d converter (Windows 10 here), and all the early games for me play perfectly in fullscreen.

For vsync patches, there's a line with two viable options to pick, if you didn't already know. "Vsync = x" where x can be 0 or 1. 0 means it will try to run at a solid 60.00 fps at all times, and 1 means it will sync to your monitor's native refresh rate (typically 60hz). You may see the fps be something like 59.94 or something extremely close to 60.00, which is fine. Usually a value of 1 is less input lag than 0, but if you have a high refresh rate monitor (144hz) then you want to use 0.

Also could be worth noting that you can mess with graphics card driver options. Some things in there may decrease the input lag. If it's Nvidia, you can set the vsync option for the game to "Use the 3D application setting" which gives full control to the vsync patches. Not sure what AMD's equivalent is.

Also I've never found "Disable fullscreen optimizations" and "Game Mode" to really do anything.